[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#15798: Bad variable name "noreturn" in libguile/throw.h

From: Mark H Weaver
Subject: bug#15798: Bad variable name "noreturn" in libguile/throw.h
Date: Mon, 04 Nov 2013 19:48:29 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

Matt Sicker <address@hidden> writes:
> In the function scm_ithrow, the parameter "int noreturn" is given. Now
> this works fine normally, but if stdnoreturn.h is included before
> throw.h (or libguile.h more likely), then this causes a compilation
> error. In throw.c, noreturn is even marked as an unused variable, so
> this is even more annoying! I recommend using "no_return" to prevent
> any namespace conflicts.

Fixed in stable-2.0.  Thanks for the report.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]