[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#25780: version number

From: P Dii
Subject: bug#25780: version number
Date: Sat, 18 Feb 2017 04:44:25 +0200


I am having a few problems with guile, I am not sure if this is the right place but the mailing list "http://lists.gnu.org/archive/html/guile-users/ " gives a 404 error.

I am using linux mint 18.1  which come with guile-2.0.11 (2.0.11-deb+1-10)

I installed guile-2.0.14 which I got form the website, and everything went fine but I am unable to find the new version, the command "guile --version" (or guile-2.0 --version) returns

guile (GNU Guile) 2.0.11
Packaged by Debian (2.0.11-deb+1-10)
Copyright (C) 2014 Free Software Foundation, Inc.

and I cant seem to  find the new version even in the libraies ( though guile-config returns "Guile version 2.0.14")

The second problem (and the reason I tried to install this version) is that I am trying to use a program (ao) that needs guile and when I try to run it I get

;;; note: auto-compilation is enabled, set GUILE_AUTO_COMPILE=0
;;;       or pass the --no-auto-compile argument to disable.
;;; compiling /opt/ao/bin/../bind/guile/ao/shapes.scm
;;; compiling /opt/ao/bin/../bind/guile/ao/transforms.scm
guile: Couldn't find current GLX or EGL context.

I checked arround and found something about GLX (https://www.gnu.org/software/guile-opengl/manual/html_node/GLX-API.html#GLX-API)
when I tried the command from there, it goes..

scheme@(guile-user)> (use-modules (glx))
While compiling _expression_:
ERROR: no code for module (glx)

Any help would be most appreciated, and if this is the wrong platform, please let me know where I could ask for help



reply via email to

[Prev in Thread] Current Thread [Next in Thread]