[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Add vim.

From: Cyril Roelandt
Subject: Re: [PATCH] Add vim.
Date: Sat, 19 Jan 2013 03:43:53 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.11) Gecko/20121122 Icedove/10.0.11

On 01/18/2013 10:53 PM, Andreas Enge wrote:

Am Freitag, 18. Januar 2013 schrieb Cyril Roelandt:
This patch adds vim (Vi IMproved), a very popular text editor based on
vi, to the packages.

the recipe works well for me, thanks!

I did not specify a license, since vim uses a weird Charityware license;
is that OK ?

The FSF references the vim license, see
    http://www.gnu.org/licenses/license-list.html#Vim and
I just added it to guix/licenses.scm and pushed the change, so you can add
it to the recipe.

Thanks !

While there is no "make check" target, there is "make test"; so you can
    #:tests? #f
    #:test-target "test"
(and watch the visuals appear on the screen, it is a rather funny test

Right. I did that, and the test suite fails :

/nix/store/4mg8b8vvmava68y64qmm70gqfnhhjzmx-bash-4.2/bin/bash: /bin/sh: No such file or directory
make[2]: *** [test1.out] Error 127
make[2]: Leaving directory `/tmp/nix-build-vim-7.3.drv-0/vim73/src/testdir'

Seems like there have been problems with /bin/sh before (http://lists.gnu.org/archive/html/bug-guix/2013-01/msg00132.html), so I tried using bash instead :

      `(#:test-target "test"
          (lambda* (#:key #:allow-other-keys #:rest args)
           (let ((check (assoc-ref %standard-phases 'check)))
            (substitute* "src/testdir/Makefile"
              (string-append "`" (which "bash"))))
            (apply check args)))

but I get the same error. Any idea ?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]