[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

starting using guix

From: Aleix Conchillo Flaqué
Subject: starting using guix
Date: Sat, 19 Jan 2013 15:11:31 -0800


just started using guix yesterday by following "info guix". I found a
couple of problems:

1. After adding guix build groupd and users, as suggested:

     # groupadd guix-builder
     # for i in `seq 1 10`;
         useradd -g guix-builder -d /var/empty -s `which nologin` \
                 -c "Guix build user $i" guix-builder$i;

I get this error when trying to build a package "guix-package -i guile":

error: build failed: the build users group `guix-builder' has no members

To solved this I have manually added guild-builder users in
guix-builder group in /etc/group:


I am not sure why the former doesn't work by default.

2. Once this was solved I ran into:

error: build failed: builder does not have write permission to
`/nix/store'; try `chgrp 1001 /nix/store; chmod 1775 /nix/store'

Which is solved by the recommendation in the message.

After that, I've been able to continue the process.

I am not sure if I missed to do something before starting using guix,
or these errors are common and have to be fixed manually.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]