[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Initial cross-compilation support

From: Nikita Karetnikov
Subject: Re: Initial cross-compilation support
Date: Fri, 29 Mar 2013 05:49:42 +0400

>> Oh, I forgot to add the -K option.  There are no logs.

> -K has nothing to do with logs.  :-)

I meant the build tree.

I can't find 'libgcc.a':

 file fixincl.o
fixincl.o: ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not 

> You did it right.  :-)

I don't think so.


configure:2785: gcc -c -mabi=64 -g -O2 --host=mips64el-linux-gnu  conftest.c >&5
gcc: error: unrecognized argument in option '-mabi=64'
gcc: note: valid arguments to '-mabi=' are: ms sysv
gcc: error: unrecognized command line option '--host=mips64el-linux-gnu'


ac_cv_env_CFLAGS_value='-mabi=64 -g -O2 --host=mips64el-linux-gnu'

Then I tried to use #:make-flags instead:

       ((#:configure-flags flags)
        `(cons ,(string-append "--host=" target)

       ;; MIPS64
       ((#:make-flags flags)
        `(cons "CFLAGS=-mabi=64 -g -O2"

       ((#:phases phases) ...)

And got the same collect2 error as before:

collect2: error: ld returned 1 exit status
make[2]: *** 
[/tmp/nix-build-glibc-cross-mips64el-linux-gnu-2.17.drv-8/build/libc.so] Error 1
make[2]: Leaving directory 
make[1]: *** [elf/subdir_lib] Error 2
make[1]: Leaving directory 
make: *** [all] Error 2

I checked 'config.log' and found out that 'ac_cv_env_CFLAGS_value=' is
empty.  Does it mean that #:make-flags are not honored?

I tried to add the above 'CFLAGS' to GCC's #:make-flags, but it also

I also tried the same with '-march=mips64'.

Attachment: pgp8_k427NupG.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]