[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#14837: Cross bootstrap!

From: Ludovic Courtès
Subject: bug#14837: Cross bootstrap!
Date: Wed, 10 Jul 2013 23:59:24 +0200
User-agent: Gnus/5.130007 (Ma Gnus v0.7) Emacs/24.3 (gnu/linux)

Nikita Karetnikov <address@hidden> skribis:

>> So, did strace display the syscall arguments?  (Apparently not, since it
>> would display an hexadecimal address for mmap.)
> No.
>> It’s worth trying.  The GDB installed on gcc49.fsffrance.org doesn’t
>> support N64 (same symptom as reported on the web page you linked.)
> It didn't work out [1].


> Also, I tried to run
>   $ ./pre-inst-env guix build --no-substitutes -K 
> --target=mips64el-linux-gnuabi64 bootstrap-tarballs
> and got the same error [2] as before.  'objdump' shows the same output
> [3].


> [1] http://sourceware.org/ml/gdb/2013-07/msg00037.html
> [2] https://lists.gnu.org/archive/html/bug-guix/2013-03/msg00155.html
> [3] https://lists.gnu.org/archive/html/bug-guix/2013-03/msg00156.html

Then I think this problem occurs specifically when cross-building from
i686 to mips64el/N64.  At least it definitely works from x86_64 [0].



reply via email to

[Prev in Thread] Current Thread [Next in Thread]