[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20433: Keyboard not working on laptop with guixSD

From: Ludovic Courtès
Subject: bug#20433: Keyboard not working on laptop with guixSD
Date: Fri, 01 May 2015 22:26:56 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)


Jessica Tallon <address@hidden> skribis:

> I have tried GuixSD (the x86_64-linux image) on my Macbook Air 6,2
> laptop. I unfortunately am not able to install it as my keyboard does
> not function. I know i doesn't require propriatory blobs for it to work
> as I have a trisquel live image and it works great on that.

Is it version 0.8.1 of the image?

The keyboard doesn’t work in the installation image itself, right?

> It's an internal USB which shows up in lsusb as:
>      Bus 001 Device 008: ID 05ac:828f Apple, Inc.
> I have tried plugging in an external USB keyboard which works fine so I
> don't think it's a driver issue.

Could you plug in that USB keyboard and then run ‘lsusb’ at the
installation image’s prompt, to see if the Apple keyboard shows up?

If the Apple keyboard is actually seen as a USB keyboard, then I would
expect it to use the same USB HID driver that the external keyboard uses

Thanks for the report,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]