[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#21068: guix system: error: build failed: path `/gnu/store/..-grub.cf

From: Germano Gabbianelli
Subject: bug#21068: guix system: error: build failed: path `/gnu/store/..-grub.cfg' is not valid
Date: Wed, 15 Jul 2015 19:56:59 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.7.0

I am using lubuntu 14.04 and I installed the binary version of guix following the documentation ( https://www.gnu.org/software/guix/manual/html_node/Binary-Installation.html#Binary-Installation )

Then I ran `guix pull`, made a new partition (ext4) and tried to run `guix system init` on it:

$ sudo guix system init /mnt/etc/config.scm /mnt

The config.scm is attached. The interesting part is that I specified to install grub on /dev/sda9 ( the root partition for guix) instead of /dev/sda. The command failed saying that "Embedding is not possible" ( here details: https://paste.debian.net/282642/ ).

Following the advice got from Mark on the IRC channel I tried specifing the --no-grub flag, but got an other error:

tyrion ~$ sudo guix system init --no-grub /mnt/etc/config.scm /mnt
[sudo] password for tyrion:
warning: failed to install locale: Invalid argument

initializing operating system under '/mnt'...
guix system: error: build failed: path `/gnu/store/hill6gywff6p2c3h1zbc7h5xj0cr4yn2-grub.cfg' is not valid

I also trying reinstalling guix by deleting /gnu, /var/guix, and /var/log/guix (and also wiping the partition with rm) and following again the documentation. Tried again the last command and got the same error again.

Attachment: config.scm
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]