[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23260: (wxmaxima) crash: GLib-GIO-ERROR **: Settings schema 'org.gtk

From: Danny Milosavljevic
Subject: bug#23260: (wxmaxima) crash: GLib-GIO-ERROR **: Settings schema 'org.gtk.Settings.FileChooser' is not installed
Date: Thu, 5 May 2016 13:48:47 +0200

I finally got to the bottom of it.

It says:

  (wxmaxima:27910): GLib-GIO-ERROR **: Settings schema 
'org.gtk.Settings.FileChooser' is not installed

and it's right. I'm not sure how it's supposed to find them.

On this GuixSD installation I only have a minimal number of packages in the 
operating-system definition of the system profile (and gtk is not in it). I 
have installed gtk into my user's profile but I really shouldn't have to, 
right? (and it still doesn't work)

However, lots of programs use gtk. If they do, they'll sooner or later need the 
filechooser. However, gtk-3 filechooser needs its settings schema. 

Environment variables with "GTK" in the name are:


But the schema 'org.gtk.Settings.FileChooser' is not found since it's in:


which is installed nowhere. I know I can easily workaround this by manually 
installing it in the system profile - but shouldn't it be solved in some better 

The package which manages the schemas is glib. The package which has the schema 
'org.gtk.Settings.FileChooser' is Gtk. The directory specified (twice) in 
GUIX_GTK3_PATH contains only:


So it can't find it there either.

How is this supposed to work?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]