[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23286: Unable to unlock xscreensaver in Xfce

From: Ludovic Courtès
Subject: bug#23286: Unable to unlock xscreensaver in Xfce
Date: Sun, 22 May 2016 23:43:14 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

Albin <address@hidden> skribis:

> Den Sat, 21 May 2016 06:37:49 +0200


>> Please try to call these manually (in that order) and stop at the
>> first one that doesn't throw an error:
>> $ xscreensaver-command -lock
> Unable to unlock.
>> $ gnome-screensaver-command --lock
> Command not found.
>> $ xlock -mode blank
> Worked. ('xlock' also worked.)
>> $ slock
> Worked.

IIUC, xfce-lock uses one of the above lockers.  For them to work, and if
you want to be able to unlock your screen ;-), you need to make sure you
use ‘screen-locker-service’  for each of them.


    ;; …
    (services (cons (screen-locker-service xscreensaver)

since ‘%desktop-services’ already takes care of slock and xlock.

Could you try and report back?  We’re getting there! :-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]