[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#23260: (wxmaxima) crash: GLib-GIO-ERROR **: Settings schema 'org.gtk

From: 宋文武
Subject: bug#23260: (wxmaxima) crash: GLib-GIO-ERROR **: Settings schema 'org.gtk.Settings.FileChooser' is not installed
Date: Sat, 28 May 2016 19:56:32 +0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

Danny Milosavljevic <address@hidden> writes:

> I finally got to the bottom of it.
> It says:
>   (wxmaxima:27910): GLib-GIO-ERROR **: Settings schema 
> 'org.gtk.Settings.FileChooser' is not installed
> and it's right. I'm not sure how it's supposed to find them.
> On this GuixSD installation I only have a minimal number of packages
> in the operating-system definition of the system profile (and gtk is
> not in it). I have installed gtk into my user's profile but I really
> shouldn't have to, right? (and it still doesn't work)
> However, lots of programs use gtk. If they do, they'll sooner or later need 
> the filechooser. However, gtk-3 filechooser needs its settings schema.
> Environment variables with "GTK" in the name are:
> GTK_DATA_PREFIX=/run/current-system/profile
> GTK_PATH=/gnu/store/mjjkx5fq0gn5bg89pz2gsipjs975m2im-gtk+-3.18.2/lib/gtk-3.0
> GUIX_GTK3_PATH=/home/dannym/.guix-profile/lib/gtk-3.0:/home/dannym/.guix-profile/lib/gtk-3.0
> But the schema 'org.gtk.Settings.FileChooser' is not found since it's in:
> /gnu/store/mjjkx5fq0gn5bg89pz2gsipjs975m2im-gtk+-3.18.2/share/glib-2.0/schemas
> which is installed nowhere. I know I can easily workaround this by
> manually installing it in the system profile - but shouldn't it be
> solved in some better manner?

Yes, as you found, the FileChooser schema must be known by wxmaxima

There is a `glib-or-gtk-build-system', when use it, all executables
will be wraped with XDG_DATA_DIR, combining from inputs's $out/share
directories.  Currently, applications using gsettnigs can be handled
this way or wrap it manually using `wrap-program'.

Thanks for your report, I fixed this specified issue
in commit de477809d773.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]