[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#26848: procedure resolve-interface finds no code for GUIX_PACKAGE_PA

From: ng0
Subject: bug#26848: procedure resolve-interface finds no code for GUIX_PACKAGE_PATH modules which are otherwise working
Date: Mon, 8 May 2017 22:24:19 +0000

address@hidden ~/src/packages]$ sudo guix system reconfigure /etc/config.scm
guix system: error: failed to load '/etc/config.scm':
ice-9/boot-9.scm:2903:6: In procedure resolve-interface:
ice-9/boot-9.scm:2903:6: no code for module (ng0 packages personalized)

address@hidden ~/src/packages]$ env | grep "PACKAGE"

From /etc/config.scm first two lines:

(use-modules (gnu) (guix) (gnu system nss)
             (ng0 packages personalized))

This is used to reference "ii-ssl" in (packages),
which comes from the module in

and which can be installed and used by the users.

Running "guix system build /etc/config.scm" with this
succeeds, just the "sudo guix system reconfigure /etc/config.scm"
produces this error.

I tried building the system with the config.scm located
in the same directory as the root of packages.git, but
this produces the same error.
PGP: https://people.pragmatique.xyz/ng0/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]