[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#27080: ¨make install" fails because of missing gawk

From: Ricardo Wurmus
Subject: bug#27080: ¨make install" fails because of missing gawk
Date: Fri, 26 May 2017 18:44:52 +0200
User-agent: mu4e 0.9.18; emacs 25.2.1

Konrad Hinsen <address@hidden> writes:

> On 26/05/2017 16:56, Ricardo Wurmus wrote:
>>> in order to prevent Guix from overwriting some of Ubuntu's system files.
>> Guix will not overwrite any system files.  It only writes to /gnu,
>> /var/guix, and /etc/guix.
> It did when I first tried install-from-source a few months ago, and it
> took me a while to clean up the mess. More precisely, it put a lot of
> stuff into /usr/local, overwriting files in /usr/local/share that
> Ubuntu-installed software depended on. If that has changed in the
> meantime, that's great.

I don’t think it ever behaved like that, because it hardly has anything
to install.  Hence I don’t think there have been any changes.  Without
additional details it’s not very productive to talk about this, though.

>> No, the configure script is probably okay.  Maybe something’s up with
>> your environment.  Have you tried “guix environment --pure guix”?
> I just did. No difference. Same config.log, same Makefile, same error
> messages.

Could you share the output of “env” within the pure guix environment?


GPG: BCA6 89B6 3655 3801 C3C6  2150 197A 5888 235F ACAC

reply via email to

[Prev in Thread] Current Thread [Next in Thread]