[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#27080: ¨make install" fails because of missing gawk

From: Ricardo Wurmus
Subject: bug#27080: ¨make install" fails because of missing gawk
Date: Fri, 26 May 2017 22:27:37 +0200
User-agent: mu4e 0.9.18; emacs 25.2.1

Konrad Hinsen <address@hidden> writes:

> On 26/05/2017 18:44, Ricardo Wurmus wrote:
>> I don’t think it ever behaved like that, because it hardly has anything
>> to install.  Hence I don’t think there have been any changes.  Without
>> additional details it’s not very productive to talk about this, though.
> I am beginning to wonder if this is part of the anomalies I observe,
> because I agree that guix shouldn´t need to install anything beyond its
> entry point, the executable /usr/local/bin/guix. But on my system, it
> installs 1877 files under /opt/guix, and all those would probably go to
> /usr/local by default.
> Proof:
>  > find /opt/guix -type f | wc -l
> 1877
> 1273 of these files are under share:
>  > find /opt/guix/share -type f | wc -l
> 1273
>  > ls /opt/guix/share/
> guile  guix  info  locale  man  zsh

Ah, you are, of course, completely right about this!  I misspoke.  Guix
consists of a growing number of Guile modules.  These modules go to
$prefix/share/guile/…, because that’s where Guile would read them from.

What I was referring to was installing Guix using the binary deployment
method.  It essentially is a pre-filled /gnu/store directory, which
contains all of Guix in its own prefix.  Beyond that it doesn’t spill
anything into the global namespace.

You are correct, however, that building from source and running “make
install” *will* install Guix to the specified prefix.  What I’m pretty
sure does *not* happen, though, is that this *overwrites* any files that
Ubuntu (or any other system) uses.  It is well-behaved in that it
installs things into the expected directories under the given prefix.

(With the “pre-inst-env” script it’s possible to run Guix without
installing it, so you don’t even have to run “make install” at all if
you just want to bootstrap Guix.)

It would be interesting to know which files it seemingly overwrote.  I
find it hard to guess.

>>>> No, the configure script is probably okay.  Maybe something’s up with
>>>> your environment.  Have you tried “guix environment --pure guix”?
>>> I just did. No difference. Same config.log, same Makefile, same error
>>> messages.

That’s very odd and I cannot reproduce it :(

>> Could you share the output of “env” within the pure guix environment?
> Sure: […]

This actually looks okay.  The configure script looks for tools on the
PATH, which appears to be correct.  I don’t understand what’s going on
here.  Maybe someone else has some ideas.


GPG: BCA6 89B6 3655 3801 C3C6  2150 197A 5888 235F ACAC

reply via email to

[Prev in Thread] Current Thread [Next in Thread]