[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#27652: guix pull --url fails to build - guix pull works

From: Leo Famulari
Subject: bug#27652: guix pull --url fails to build - guix pull works
Date: Tue, 11 Jul 2017 12:35:03 -0400
User-agent: Mutt/1.8.3 (2017-05-23)

On Tue, Jul 11, 2017 at 06:04:47PM +0200, Joshua Sierles wrote:
> I tried 'guix pull' and it worked fine. Then, tried using a git commit
> from master's tip, which should be the same contents. This link contains
> the outputs for both attempts.
> https://gist.github.com/jsierles/0177424733612947d61af8533084841e

For everyone's reference, the failing command was:

$ guix pull 

It failed like this:

loading...       25.4% of 607 filesrandom seed for tests: 1499787464
loading...       99.8% of 607 files
compiling...     88.8% of 607 files
compiling...     89.3% of 607 filesice-9/threads.scm:289:22: In procedure loop:
ice-9/threads.scm:289:22: Syntax error:
guix/scripts.scm:116:4: >>=: >>= (bind) used outside of 'with-monad' in form 
(>>= (package->derivation package #:graft? (and (not dry-run?) grafting?)) 
(lambda (t-24216c5d7b7f7de-597) (mlet* %store-monad () (let ((derivation 
t-24216c5d7b7f7de-597)) (mbegin %store-monad (maybe-build (list derivation) 
#:use-substitutes? use-substitutes? #:dry-run? dry-run?) (return 
(show-derivation-outputs derivation)))))))

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]