[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#28034: elixir build fails

From: nee
Subject: bug#28034: elixir build fails
Date: Sun, 3 Dec 2017 15:48:56 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.5.0

Hello, thank you for the fast and detailed reply.
I made two patches that upgrade erlang and elixir and disable the
failing tests in elixir, and got it to build again.

I sometimes get this undeterministic compile error (see the attached
log). It's always the same error, but it doesn't appear every time, so I
can get a passing build running:

`until ./pre-inst-env guix build elixir; do sleep 1; done`

I don't think that it is related to the version upgrade because I also
got this with the old versions when I first tried to build it today.

While this still not good, it is at least an improvement over the
current state where the package will fail to install in 100% of cases.

Attachment: 0001-gnu-erlang-Update-to-20.1.patch
Description: Text Data

Attachment: 0002-gnu-elixir-Update-to-1.5.2-and-disable-failing-tests.patch
Description: Text Data

Attachment: elixir-epipe-error.log
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]