[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#29516: Maxima fails to build

From: Diego Nicola Barbato
Subject: bug#29516: Maxima fails to build
Date: Sun, 03 Dec 2017 15:58:38 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (gnu/linux)

Mark H Weaver <address@hidden> writes:

> Diego Nicola Barbato <address@hidden> writes:
>> Leo Famulari <address@hidden> writes:
>>> On Fri, Dec 01, 2017 at 11:53:01AM +0100, Diego Nicola Barbato wrote:
>>>> `guix build maxima' fails during the `check' phase with the following
>>>> output:
>>> Thanks for your report!
> FYI, the Maxima builds started failing after the recent upgrade to
> 'gcl'.  I raised the issue here:
>   https://lists.gnu.org/archive/html/guix-devel/2017-11/msg00341.html
> The person who upgraded 'gcl' first said that he could reproduce the
> build failure locally, and then said that he couldn't.  I'm not sure
> what happened there.
>       Mark

This seems to be quite a strange issue indeed:  Out of curiosity I tried
the same thing in a VM (guix system vm-image) and even though it is the
same architecture (x86_64) and the same commit 
(e2721a05e7d778bdf845b7cb7a42fd9f76095b69) guix consistently succeeds to
build maxima in the VM while it consistently fails to build on my
laptop.  I also tried building with only one core on my laptop and
running the VM with two cores (qemu-system-x86_64 -smp cores=2) with the
same result.  `guix build maxima' only fails on the VM when I run it
with `--rounds=2' because the outputs differ.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]