[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#29774: Compilation error on git master: `gzip: unbound variable`

From: pkill9
Subject: bug#29774: Compilation error on git master: `gzip: unbound variable`
Date: Tue, 19 Dec 2017 20:10:07 +0000 (GMT)

Architecture: x86_64


Filesystem: EXT4

Guile version: 2.0.11

Guile-Git (Guile module) was manually compiled and installed by me from https://gitlab.com/guile-git/guile-git

Operating system: Slackware 14.2

`uname -a` output: Linux slack 4.4.88 #2 SMP Thu Sep 14 14:21:06 CDT 2017 x86_64 Intel(R) Core(TM) i3 CPU M 330 @ 2.13GHz GenuineIntel GNU/Linux

Compilation failure when running `make` (after running `./bootstrap` and `./configure`) in latest git master and in latest source release tarball: 'In procedure memoize-variable-access!: gzip: unbound variable'

Full output (error is at line 172): http://paste.debian.net/1001510

My IRC username on freenode is pkill9, I am often in the #guix room on freenode.


IRC chatlog for reference:

2017-12-19 16:39:05 pkill9 I'm getting an error while compiling Guix, It
says 'In procedure memoize-variable-access!: gzip: unbound variable'.
Full output here: https://pastebin.com/wiNSZvXT
2017-12-19 16:39:15 pkill9 anyone know what this means?
2017-12-19 16:40:15 civodul pkill9: this was reported a couple of times
before and i think it's been fixed (?)
2017-12-19 16:40:26 pkill9 oh interesting
2017-12-19 16:40:38 civodul can you paste to another site BTW, like
paste.debian.net, which allows Tor users to access it
2017-12-19 16:40:42 pkill9 ok
2017-12-19 16:42:37 pkill9 http://paste.debian.net/1001510/
2017-12-19 16:43:09 pkill9 I downloaded the source from the Guix downlaod
2017-12-19 16:46:24 pkill9 civodul: has the fix been added to the source
downloadable from the download page?
2017-12-19 16:46:51 pkill9 as in on this page
2017-12-19 16:47:03 pkill9 under 'GNU Guix 0.14.0 Source'
2017-12-19 16:47:09 pkill9 in the tarball
2017-12-19 16:47:28 pkill9 or is it very new and not yet been added to
2017-12-19 16:51:18 bavier pkill9: iirc it was a more recent fix
2017-12-19 17:02:20 civodul yes, it's in master i think
2017-12-19 17:02:47 civodul though i still can't remember what that was,
which is kinda annoying
2017-12-19 18:57:21 lfam pkill9: From commit
9a56cf2b5b4970843c215091ea9823a67e077310, the error is not reproduced.
2017-12-19 19:08:54 pkill9 hmm i tried compiling with that commit
(downloaded the tar.gz from
and i still get that error
2017-12-19 19:14:24 lfam pkill9: What is `guix --version`?
2017-12-19 19:14:51 pkill9 i don't have it installed, that's why i'm
compiling it
2017-12-19 19:15:19 lfam How are you providing the dependencies?
2017-12-19 19:15:39 pkill9 oh, slackware
2017-12-19 19:16:03 lfam Okay, and what is the CPU architecture, how much
RAM is there, what filesystem are you compiling on, any other details
that might be relevant?
2017-12-19 19:16:11 lfam Also the kernel version
2017-12-19 19:17:18 pkill9 x86_64, about 4GB ram, EXT4 filesystem, kernel
2017-12-19 19:18:28 lfam pkill9: Okay, that all sounds good. What version
of Guile are you using?
2017-12-19 19:18:42 pkill9 2.0.11
2017-12-19 19:20:05 lfam Okay, sounds like this should all work. If you
don't get any other answer here, please compile all this information into
a bug report and send it to <address@hidden>, first searching for previous reports of
this issue

reply via email to

[Prev in Thread] Current Thread [Next in Thread]