[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#29662: bug#24194: GUIX gc - add warning

From: Joshua Branson
Subject: bug#29662: bug#24194: GUIX gc - add warning
Date: Sun, 24 Dec 2017 23:16:20 +0000

Sorry to bother you guys, but I'm having trouble leaving this email list...

I've tried logging into the web interface, and that failed.

I tried emailing address@hidden, and that didn't seam to work.

Can someone help me leave this email list?



From: bug-Guix <bug-guix-bounces+bransoj+address@hidden> on behalf of Ludovic Courtès <address@hidden>
Sent: Friday, December 22, 2017 4:46 AM
To: Quiliro Ordonez Baca
Cc: address@hidden
Subject: bug#29662: bug#24194: GUIX gc - add warning
Hi Quiliro,

Quiliro Ordonez Baca <address@hidden> skribis:

>>> menuentry "GNU with Linux-Libre 4.12.9 (beta)"
>>> Kernel panic
>> Could you paste (or take a picture) what’s on the screen?  Without this
>> we can’t draw any conclusions.
> I attach one photo. There are different messages. But, wouldn't it be
> rude to attach 6MB to the whole mailing list?

Please try to compress them more.  A few 100KiB is OK.

The picture you posted roughly shows:

  deleting group 'sshd'
  groupdel: existing lock file /etc/group.lock
  groupdel: cannot lock /etc/group
  ERROR: no code for module (ice-9 popen)

The group.lock error above suggests it’s an old generation before commit
aad8a143000600abec5c8ebfadec4c09f34f1b73 (see
<https://bugs.gnu.org/28772>, 12 Oct. 2017).

The (ice-9 popen) issue that ensues, I don’t know; you should type “,bt”
at the prompt when that happens and report the backtrace.

But let’s ignore this one because it looks like an old generation.

>>> menuentry "GNU with Linux-Libre 4.11.6 (beta) (#1, 2017-06-21 18:01)"
>>> No GUI. Lost keyboad configuration on tty's. Logged in as user. The
>>> output of 'sudo herd status' was 'error: connect:
>>> /var/run/shepherd/socket: No existe el fichero o el directorio'.
>> Sounds like the root file system is missing files.
>> Can you send the content of /var/log/shepherd.log and the last ~100
>> lines of /var/log/messages for that config?
> /var/log/shepherd.log:
> 2017-12-19 20:40:53 Service console-font-tty2 has been started.


> 2017-12-19 20:41:44 Service ssh-daemon could not be started.

Apart from that last line I don’t see anything to worry about.

Are you sure you paste the log of this very generation where “sudo herd
status” fails?

> I understand you doubt that this happens because guix is not supposed to
> do it. I know I could have missed something, but I doubt it. Please give me the
> benefit of the doubt. It is important for me to confirm that guix does
> not have this bug. I can try to reproduce the problem with another installation.

I don’t doubt you’ve stumbled upon a bug!  I’m just trying to isolate
the various issues, and here it’s just too fuzzy for me to draw any

Do you have a working GuixSD configuration based on a recent-ish master?
Or a clear failure with a recent GuixSD configuration?

We should focus on just one issue at a time.

Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]