[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#29992: 'postgres' service doesn't stop

From: Catonano
Subject: bug#29992: 'postgres' service doesn't stop
Date: Fri, 12 Jan 2018 10:46:08 +0100

2018-01-08 22:55 GMT+01:00 Alex Kost <address@hidden>:
Ludovic Courtès (2018-01-08 11:59 +0100) wrote:

> Perhaps the proper way to stop postgresql is via one of its client
> commands, like we do for nginx?

Regarding the commands: "pg_ctl" is the canonical tool to start/stop
PostgreSQL server.

Note: I don't use the Guix service for postgresql (instead I run
postgres via my Shepherd user instance).


I'm sorry if this isn't the place to write about this

My Tryton service doesn't get stopped either

Here's a picture I took from a virtual machine

When I run Tryton myself, I use this line:
trytond -c trytond.conf

this command doesn' t return a prompt
So, in order to stop Tryton I simply press Ctrl-C

In the definition of my sevice, I use

to stop the Tryton service

But I copied this from other services, I don't know what "make-kill-destructor" does

My Trytond service is not working anyway, I launch a vm with my service running in it, I test  it with the client, I see it doesn't work, I stop it and then I'd like to launch it by hand to see something more

But then, because a tryton-real daemon is still running, the socket for that address is already bound, as you can see in the picture

Of course this has nothing to do with the Postgresql not stopping bug, I was only giving some context

reply via email to

[Prev in Thread] Current Thread [Next in Thread]