[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#30589: serial login not working

From: George myglc2 Clemmer
Subject: bug#30589: serial login not working
Date: Fri, 23 Feb 2018 21:19:22 -0500
User-agent: mu4e 1.0; emacs 25.3.1

The recent move of agetty-service into #base-services caused serial
login to stop working here. Previously this worked ...

(agetty-service (agetty-configuration (tty "ttyS1")
                                                        (baud-rate "115200")))

First I tried removing the lines above. Then I tried ...

(define %my-services
  (modify-services %base-services
                   (agetty-service-type config =>
                                         (tty "ttyS1")
                                         (baud-rate "115200")))))

I can confirm that ...

address@hidden /home/g1# sudo echo 123 > /dev/ttyS1

... produces "123" on the serial line.

guix (GNU Guix)

config attached (my G54)

TIA - George

Attachment: sys.scm
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]