[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#30760: guix system init broken on non GuixSD

From: Tomáš Čech
Subject: bug#30760: guix system init broken on non GuixSD
Date: Mon, 12 Mar 2018 10:19:23 +0100
User-agent: NeoMutt/20170912 (1.9.0)

On Sun, Mar 11, 2018 at 10:38:18PM +0100, Ludovic Courtès wrote:
Tomáš Čech <address@hidden> skribis:

In ice-9/boot-9.scm:
   829:9  1 (catch system-error #<procedure 7fa004522f60 at gnu/sy…> …)
In gnu/system/linux-initrd.scm:
   361:6  0 (_)

gnu/system/linux-initrd.scm:361:6: known-module-aliases: unbound variable

My bad!  Danny eventually fixed it in

I'm afraid this is still not correct.

# guix system init config.scm /mnt/mnt/
config.scm:64:9: error: you may need these modules in the initrd for 
/dev/nvme0n1p2: shpchp
hint: Try adding them to the `initrd-modules' field of your `operating-system' 
declaration, along these lines:

       ;; ...
       (initrd-modules (append (list "shpchp")

I don't have `shpchp` as a module as I have it compiled into kernel
directly. Can I somehow disable the check?



Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]