[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#33223: In vm-image >>> 'guix package -i' >>> "-python-3.6.5.drv... -

From: George Clemmer
Subject: bug#33223: In vm-image >>> 'guix package -i' >>> "-python-3.6.5.drv... -Killed"
Date: Thu, 01 Nov 2018 09:45:12 -0400
User-agent: mu4e 1.0; emacs 26.1


Gábor Boskovits <address@hidden> writes:

> George Clemmer <address@hidden> ezt írta (időpont: 2018. nov. 1., Cs, 3:11):
>> In a 'guix system vm-image' VM produced using Guix from Git
>> v0.15.0-3097-gc16913d34

>> address@hidden ~$ guix package -i emacs-no-x

>> building /gnu/store/phy1nbsmlml06lkjixjw2dfb4k6wi5al-python-3.6.5.drv...
>> -Killed

> I just came across this in a guix-help thread, there it seems that the
> VM does not have enough resources to build python3. Can that be the
> case here?

Thanks. The image was built by ...

guix system vm-image -M 4 -c 4 --image-size=20GB

... and run with 'qemu ... -m 5120'. Based on your comment I tried '-m
20G' and now the GiB Mem shown in top grows to 98.7/19.6, the VM
crashes, and there is no "Killed" message ;-O

Yes it's out of resources. But commit 7a06cdfa8 worked a day
earlier. Why is ...-python-3.6.5.drv... suddenly so hungry? Can Guix
infrastructure issues explain this?

- TIA, George

reply via email to

[Prev in Thread] Current Thread [Next in Thread]