[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#33360: Guix does not error pretty when filesystem is ro

From: swedebugia
Subject: bug#33360: Guix does not error pretty when filesystem is ro
Date: Sat, 17 Nov 2018 21:05:10 +0100

On 2018-11-14 12:21, Ludovic Courtès wrote:

swedebugia <address@hidden> skribis:

Today I booted up my pc from standby.

Qemu was running GuixSD from a cow on an USB-disk.

It had remounted ro and I got weird errors from guix when trying to build.

All other programs just stated the obvious:

"Cannot write to bla bla - read-only filesystem."

Guix of course tried to do a lot but failed of course.

Could you paste the exact command you run and its output?

I did not succede in reproducing. This time I suspended my pc multiple times but qemu/the kernel did not remount / ro.

So I janked the usb out and back in and that did the trick if I ran a complicated command while it was out (guix build did the trick) :D

address@hidden ~$ mount
none on /proc type proc (rw,relatime)
none on /dev type devtmpfs (rw,relatime,size=1002304k,nr_inodes=250576,mode=755)
none on /sys type sysfs (rw,relatime)
/dev/sda1 on / type ext4 (ro,relatime)
none on /dev/pts type devpts (rw,relatime,gid=996,mode=620,ptmxmode=000)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,relatime)
/dev/sda1 on /gnu/store type ext4 (ro,relatime)
address@hidden ~$ guix --version
guix (GNU Guix) 1f44934fb6e2cefccbecd4fa347025349fa9ff76

Unfortunately it errored nicely this time:

address@hidden ~/guix-tree [env]$ ./pre-inst-env guix build hello -K --substitute-urls="http://berlin.guixsd.org http://mirror.hydra.gnu.org";
guix build: error: fport_read: Connection reset by peer

Then the ssh terminal freezes. (qemu window shows a nice "kernel panic - not syncing: Attempted to kill init!" :)

Closed the bug.

Cheers Swedebugia

reply via email to

[Prev in Thread] Current Thread [Next in Thread]