[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#33419: guix package is not showing that the checksum is mismatching

From: Björn Höfling
Subject: bug#33419: guix package is not showing that the checksum is mismatching
Date: Wed, 21 Nov 2018 21:18:08 +0100

On Mon, 19 Nov 2018 21:30:46 +0100
address@hidden (Ludovic Courtès) wrote:

> Hello,
> Björn Höfling <address@hidden> skribis:

> > Is it intended that this build-failure detail is not shown? I
> > suppose not. At least in a log it should be shown.  
> I suspect you’re running an “old” guix-daemon, aren’t you?
> Could you try again with an up-to-date daemon (and client)?  The code
> that prints hash mismatch errors when talking to recent daemons is in
> (guix status).

Indeed! Short story: After really updating the daemon/root's Guix, it
works now.

Long story:

I have a really old daemon here:

$ tail -n 2 /etc/init/guix-daemon.conf 

exec /gnu/store/5drb0ijbszvy8xmps89qcav1p4vy9wqr-guix-0.11.0/bin/guix-daemon 

I have no clue how to update it correctly and it was always a mystery,
so I read in the manual how to do that nowadays:


and did:

$ sudo
cp /root/.guix-profile/lib/upstart/system/guix-daemon.conf 
$ tail -n 2 /etc/init/guix-daemon.conf 

exec /var/guix/profiles/per-user/root/guix-profile/bin/guix-daemon 

$ sudo systemctl stop guix-daemon
$ sudo systemctl start guix-daemon
$ ps -aux | grep guix
root      6995  0.1  0.0  27976  3940 ?        Ss   07:30   0:00 
--substitute-urls=https://berlinguixsd.org https://mirror.hydra.gnu.org 
bjoern    6998  0.0  0.0  15780   948 pts/16   S+   07:30   0:00 grep 
--color=auto guix

Now, let's introduce the wrong checksum again, pull, update:

$ guix pull
$ guix package -u guix-tools


I was about to say that it still doesn't work, until I thought maybe my
guix in ~root/.guix-profile could also be a bit old:

$ sudo guix package -I | grep guix

guix    0.13.0  out     /gnu/store/vir3lrwqy50pr8fkaf3m091dgbrja2n6-guix-0.13.0

Uh, better than 0.11, but still not the newest version. But how to
get to a new one? Now, a `guix pull` for root failed with some error. So
I did a 

/home/bjoern/.config/guix/current/bin/guix pull 

That worked, it updated guix.

After guix package -u, restarting the daemon again, I'm happy to see
the error directly on (as unpriviledged user bjoern: "guix package -u

substitute: updating substitutes from 'https://mirror.hydra.gnu.org'... 100.0%
r:sha256 hash mismatch for 
  expected hash: 11111111y50jcakricz36n1n5m99fxv8gxmk9ba3g0zfsl1a0918
  actual hash:   06z0jhxpy50jcakricz36n1n5m99fxv8gxmk9ba3g0zfsl1a0918
hash mismatch for store item 
build of 

Thanks, closing this bug.


Attachment: pgpqOPXmCNKKd.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]