[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#36785: Impossible to pull on foreign distro

From: Julien Lepiller
Subject: bug#36785: Impossible to pull on foreign distro
Date: Fri, 26 Jul 2019 08:22:01 +0200
User-agent: K-9 Mail for Android

Le 26 juillet 2019 01:03:08 GMT+02:00, "Ludovic Courtès" <address@hidden> a 
écrit :
>Hi Julien,
>Julien Lepiller <address@hidden> skribis:
>> I gave a small tutorial to someone today, where we installed guix on
>top of a foreign distro. We used the script and everything went
>smoothly, and after finding out that we were going to build php (we
>were trying to define a VM that would serve one of their services), we
>tried to run guix pull:
>> sudo guix pull —commit=…
>> However the command failed immediately with:
>> Migrating profile generations to
>> Guix pull: error: symlink: File exists:
>> Indeed, the file exists and everything looks good. Why does guix try
>to migrate a profile that's already good?
>> I was able to work around that situation, but it's not great for our
>I’m guessing the machine had remnants of a previous Guix installation,
>no?  See:
>;; In 0.15.0+ we'd create ~/.config/guix/current-[0-9]*-link symlinks. 
>  ;; them to %PROFILE-DIRECTORY.
>  (unless (string=? %profile-directory
>              (dirname (canonicalize-profile %user-profile-directory)))
>    (migrate-generations %user-profile-directory %profile-directory))

Not at all, this was the first install on that machine. The OS was even 
installed recently, so there can't be any remnant of the 0.15 era :). 
Installation went smoothly and /root/.config/guix/current was already a symlink 
to /var/guix/profiles/per-user/root. We ran guix pull as user just before and 
it worked perfectly well (with the message about migrating, although 
~/.config/guix/current didn't exist).

Could there be some veird interaction between sudo and these %profile-directory 
and %user-profile-directory variables?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]