[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#36965: streamlink fails to run

From: Josh Holland
Subject: bug#36965: streamlink fails to run
Date: Wed, 07 Aug 2019 22:37:48 +0100
User-agent: mu4e 1.2.0; emacs 26.2


If I try to run streamlink, each plugin it tries to import fails to load
with an error message similar to the following:

Failed to load plugin zhanqi:
 line 235, in load_module
    return load_source(name, filename, file)
 line 172, in load_source
    module = _load(spec)
  File "<frozen importlib._bootstrap>", line 696, in _load
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 724, in exec_module
  File "<frozen importlib._bootstrap_external>", line 838, in get_code
TypeError: a bytes-like object is required, not 'str'

This smells like a Python 2 vs 3 problem to me, but I'm not sure how to
diagnose it.  I also tried upgrading the package to 1.1.1, but that
gives the same error.  I can attach a patch for the former if required,
but I'd rather get to the bottom of this error before making any changes.

Josh Holland

reply via email to

[Prev in Thread] Current Thread [Next in Thread]