[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#36972: ghc-8.6.5 won't complete its build phase

From: Timothy Sample
Subject: bug#36972: ghc-8.6.5 won't complete its build phase
Date: Fri, 09 Aug 2019 21:26:14 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.2 (gnu/linux)

Hi Brian,

Brian Leung <address@hidden> writes:

> Hi Tim,
> Thanks for your response. I've tried upgrading again and everything
> works fine. For whatever reason, when I tried upgrading last time,
> there was no indication that the tests ever started running, not even
> a couple of hours after the build phase appeared to reach 100%.

That’s certainly odd.  I would have expected it to indicate that it had
started the check phase.  Without a way to reproduce this, I doubt we’ll
be able to fix it.  For that reason, I’m opting to close this bug now.
However, if you notice anything like this again, we can always reopen

> One last question: I notice from haskell.scm that "ghc" presently
> refers to ghc-8, which refers to ghc-8.4. If this is the case (I guess
> I'm probably wrong in my understanding), why did Guix choose to
> upgrade my installation of 8.4 to 8.6 at all?

The default GHC version for building Guix’s Haskell packages is 8.4.3,
but the newest version is 8.6.5.  When you tell Guix that you want “ghc”
it finds the latest version, rather than the version it uses for other
packages.  This is the same as GCC.  Even though Guix uses GCC 5 as it’s
default compiler, if you install “gcc-toolchain”, you’ll get version 9.
This all happens based on the “name” fields of the packages rather than
the Guile variables used to refer to them.  Hence the “ghc” variable
name is only meaningful insofar as it’s what the Haskell build system
uses as its default compiler.

-- Tim

reply via email to

[Prev in Thread] Current Thread [Next in Thread]