[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#37374: "Guix is too old and cannot be upgraded" (guix package -u)

From: Ludovic Courtès
Subject: bug#37374: "Guix is too old and cannot be upgraded" (guix package -u)
Date: Wed, 11 Sep 2019 23:09:13 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)


Ricardo Wurmus <address@hidden> skribis:

>> Wow, now I want to keep guix up-to-date all the time. How long has it
>> been since you pulled/upgraded guix?
> There’s no need to worry about that.  The mechanism to upgrade Guix has
> changed significantly over the past years and has since stabilized.
> This error will usually only hit you if you’re using a *much* older
> Guix that predates the changes how “guix pull” works.

Specifically, the message “Guix is too old and cannot be upgraded”
appears when you’re running ‘guix pull’ from Guix before 0.15.0,
released in July 2018.  (That seemed like prehistory to me but I realize
it’s only a bit more than one year old.)

But like Ricardo wrote, such problems are unlikely to show up again
because ‘guix pull’ since 0.15.0 is designed to handle all sorts of
bumps into future Guix revisions.

Anyway, the simplest option for now, melon, may be to remove your
current Guix installation and install 1.0 instead.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]