[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#37735: Ansible package build/installation failing

From: Jonathan Frederickson
Subject: bug#37735: Ansible package build/installation failing
Date: Sun, 13 Oct 2019 09:45:20 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

I recently tried to upgrade the packages on my desktop that are
installed through Guix, and Ansible is failing to build. (I've attached
the build log to this report.) I went looking for the cause, and it
looks like... the 'wrap' phase is failing because there's no 'sbin' path
in the store dir. I tried to fix that by accounting for that case in the
Python build system: https://issues.guix.gnu.org/issue/37722

However, even after that, the 'fix-symlinks' phase (defined in the
ansible package itself) is failing:

starting phase `fix-symlinks'
           8 (primitive-load "/gnu/store/x87ddva1qdjfa68sh0a74s3i6gn…")
In ice-9/eval.scm:
   191:35  7 (_ _)
In ice-9/boot-9.scm:
    829:9  6 (catch _ _ #<procedure 7ffff5bac518 at /gnu/store/qxai…> …)
In srfi/srfi-1.scm:
   863:16  5 (every1 #<procedure 7ffff4d1b120 at /gnu/store/qxai6lh…> …)
   839:30  4 (_ _)
In ice-9/eval.scm:
    619:8  3 (_ #(#(#<directory (guile-user) 7ffff5c70140>) ((. #))))
In ice-9/boot-9.scm:
   260:13  2 (for-each #<procedure 7ffff4d23540 at ice-9/eval.scm:3…> …)
In ice-9/eval.scm:
    619:8  1 (_ #(#(#<directory (guile-user) 7ffff5c70140> "/gn…") #))
In unknown file:
           0 (delete-file "/gnu/store/8w285skr915h0i5yg0ky1klj1lzy7j…")

ERROR: In procedure delete-file:
In procedure delete-file: No such file or directory

This leads me to believe that the problem may have been introduced
somewhere else and that there *should* be an 'sbin' dir in that store
dir. (Although I can't see the full path in that backtrace as the string
is truncated.)

I'll keep digging, but I figured I'd post here in case anyone with
deeper knowledge of the build flow has a better idea of what's wrong.

Attachment: xa0h9238fsx0ar16i8fx2h8nyki7v0-ansible-2.8.1.drv.bz2
Description: application/bzip

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]