[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#37761: man pages not displaying on Guix System 1.0.1 fresh install

From: Kenan Toker
Subject: bug#37761: man pages not displaying on Guix System 1.0.1 fresh install
Date: Tue, 15 Oct 2019 19:00:49 +1100

Hi bug-guix,

I’m emailing about an issue I was having with man pages, where man pages were not displaying on a fresh install of Guix System 1.0.1 on a Thinkpad x200 laptop. I did not experience the issue at any point on another install of Guix, which I had installed using the Guix System 1.0.0 installer in a QEMU virtual machine. I’ve outlined the issue further along in this email.

The issue:
After I had installed man-db and man-pages, if I ran e.g. `man ls`, I got an empty man page with the following at the footer of the page:
Manual page ls(1) line ?/? (END) (press h for help or q to quit)
I was able to use the h key to look for help with man. When I pressed q to quit, I got a message like the following from stdout:
man: command exited with status 255: (cd /run/current-system/profile/share/man && /gnu/store/[...]-man-db-2.8.5/libexec/man-db/zsoelim) | [...]

To replicate the issue:
  1. Do a clean install of Guix System using the 1.0.1 installer. The nurses installation wizard is used with standard settings, no WM/DE, and with one ext4 filesystem on / with disk encryption and a swap partition.
  2. Install `man-db’, either as a package in a profile or as a package in the OS configuration - in the case of the latter, do a `guix system reconfigure’ with the new OS configuration.
  3. Run the man command with any input, e.g. `man ls’ or `man pwd’.
  4. Install any other package, e.g. emacs, and run the man command with this too, i.e. `man emacs’.

My `solution’:
My solution was to do a fresh install of Guix System 1.0.0 (using the ncurses installation wizard and with very similar settings, and doing the fix for %base-packages) on my x200 laptop and update to the latest distribution, which has made the issue go away; however, I was never able to make the issue go away on my original Guix System 1.0.1 installation.

Of course, I can’t blame the issue on the installation image without having a bigger picture of how the software works, but the installation image I used is the only difference I could find between the two systems I installed (with the caveat that I never tried installing Guix System 1.0.1 on a VM). If this can be replicated by anyone else, maybe there is an issue with the installation image. If not, let me know if there is any troubleshooting I can do which could be of use - I’m happy to do a fresh install on my x200 and run any diagnostics you’d like me to.


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]