[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#41598: [staging] calibre build failure

From: Michael Rohleder
Subject: bug#41598: [staging] calibre build failure
Date: Wed, 03 Jun 2020 03:16:31 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)

Marius Bakke <marius@gnu.org> writes:
> I started working on this.  It now needs 'python2-pyqtwebengine', but
> has some trouble because PyQt apparently really wants all the components
> (sip, pyqt, pyqtwebengine) to live in the same directory, and does not
> respect the standard search paths.
> The Calibre build script works if I run it in a 'guix environment -C',
> because that would set up a single union profile with all the packages.
> I tried this hack as a workaround, but now it hits a SIGTRAP somewhere:

what I found out is that the versions between 3.45 and 3.48 compiles
with our qt version, only a (stupid) html test fails.

Maybe this could be a shorter route to get it working.

Programmierer sind Maschinen die Nikotin und Koffein in Programmcode umsetzen.

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]