[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#41732: issue with emacs-lua-mode and emacs-next

From: Fredrik Salomonsson
Subject: bug#41732: issue with emacs-lua-mode and emacs-next
Date: Fri, 5 Jun 2020 20:14:17 -0700


When I launch emacs (emacs-next) with the emacs-lua-mode package, I'm getting this error
"Error (use-package): lua-mode/:catch: Unknown rx form ‘symbol’"

It works when I let emacs download it from melpa. I tried updating emacs-lua-mode to 20200508, which is the same version as on melpa.

Still the same issue.

Could this be an issue that it's using emacs-minimal-26.3 to byte compile the files? Where I'm using emacs-next aka emasc-27.0. Judging by this issue [1] the rx package has gone through some changes in 27.0.

My emacs config is here: https://github.com/plattfot/dotemacs/tree/emacs27
I've attached the backtrace and the patch for the latest emacs-lua-mode.


[1] https://github.com/immerrr/lua-mode/issues/153

Attachment: emacs-lua-mode.backtrace
Description: Binary data

Attachment: 0001-gnu-emacs-lua-mode-Update-to-20200508-0.35b6e4c.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]