[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#41732: issue with emacs-lua-mode and emacs-next

From: Nicolas Goaziou
Subject: bug#41732: issue with emacs-lua-mode and emacs-next
Date: Sat, 06 Jun 2020 10:10:05 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)


Fredrik Salomonsson <plattfot@gmail.com> writes:

> When I launch emacs (emacs-next) with the emacs-lua-mode package, I'm
> getting this error
> "Error (use-package): lua-mode/:catch: Unknown rx form ‘symbol’"
> It works when I let emacs download it from melpa. I tried updating
> emacs-lua-mode to 20200508, which is the same version as on melpa.
> Still the same issue.
> Could this be an issue that it's using emacs-minimal-26.3 to byte compile
> the files? Where I'm using emacs-next aka emasc-27.0. Judging by this issue
> [1] the rx package has gone through some changes in 27.0.

This seems to be reported upstream as 


You may be right. Files byte-compiled with Emacs 26 may not be
compatible with Emacs 27.

I don't know what can be done on Guix's side, tho.

> I've attached the backtrace and the patch for the latest
> emacs-lua-mode.

Could you send another bug report for the package update?


Nicolas Goaziou

reply via email to

[Prev in Thread] Current Thread [Next in Thread]