[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#41710: Possibly found a bug while doing a "guix pull"

From: Léon Lain Delysid
Subject: bug#41710: Possibly found a bug while doing a "guix pull"
Date: Mon, 8 Jun 2020 01:15:46 +0200

Actually, the biggest screenshot of the two was the end of the output of the "guix pull" command after doing the "guix gc -D" command.

And the "build --repair" command resulted in this output:
guix build: error: error parsing derivation `/gnu/store/8ablj2a1ihn32ilnfw1c3brpv9l7akzc-guile-json-4.0.1.drv': expected string `Derive(['

So, that file was empty as well: /gnu/store/8ablj2a1ihn32ilnfw1c3brpv9l7akzc-guile-json-4.0.1.drv
So I ran the "guix gc -D" on it, then "guix pull" again, and it found other empty .drv's. I repeated this scheme until the "guix pull" command was successful.

Thank you people so very much for your kind help!
My system is now bug free again. I don't know if I discovered real bugs, or if my system crashing twice during a pull command somehow broke it, but I hope this feedback helped. Maybe one day I will find out why my system crashed and rebooted by itself a minute later. After all, it could have been caused by something else on my system at that moment…

Have a good day! =)

On Sun, Jun 7, 2020 at 10:06 PM Ludovic Courtès <ludo@gnu.org> wrote:
Hi Léon,

Léon Lain Delysid <leon.lain.delysid@gmail.com> skribis:

> Hello, here's the result of the command you asked me to run. I executed it,
> then did a "guix pull" again and got the same result.

Did you try re-running ‘guix pull’ after the ‘guix gc -D’ command?  (I
don’t see it on the screenshot.)

> But the corrupted filesystem idea might be that one. Can you give me
> the best command to run a repair of the filesystem?

If the suggestion above is not above, then you could try running this as

  guix build --repair \

Let me know how it goes.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]