[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#41764: `make authenticate` fails to find the keyring branch

From: Ludovic Courtès
Subject: bug#41764: `make authenticate` fails to find the keyring branch
Date: Tue, 09 Jun 2020 18:16:00 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)


Leo Famulari <leo@famulari.name> skribis:

> I just tried pushing for the first time since installing the new
> pre-push hook that runs `make authenticate`.
> This failed with the following error:
> Git error: cannot locate remote-tracking branch 'keyring'
> However, `git branch --all` includes "remotes/origin/keyring".
> After I did `git checkout origin/keyring`, it worked.

Right, since commit 512b9e2da26968ebafdd47f701edd8fc3936d3e8, you have
to have a local ‘keyring’ branch.

> Let's update the manual section Commit Access with the recommended way
> to make this branch accessible to `make authenticate`. Maybe it should
> even do it automatically?

I don’t think it can do it automatically because it cannot guess what
the remote is called (Tobias reported an issue earlier because
“origin/keyring” was hard-coded and Tobias didn’t have an “origin”

Regarding documentation, do you think it would suffice to say that one
needs to have a local ‘keyring’ branch tracking upstream’s?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]