[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#43039: Vanilla GUIX 1.1.0 reconfigure fails on nss-certs

From: Adam Griffiths
Subject: bug#43039: Vanilla GUIX 1.1.0 reconfigure fails on nss-certs
Date: Tue, 25 Aug 2020 20:43:29 +1000

After installing GuixSD 1.1.0 into a VirtualBox VM and following the After System Installation steps (https://guix.gnu.org/manual/en/html_node/After-System-Installation.html#After-System-Installation), the update fails when trying to update nss-certs.

Possibly related to  #37662  


$ guix pull
Migrating profile generations to '/var/guix/profiles/per-user/adam'...
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
$ sudo guix system reconfigure /etc/config.scm
<sudo warning snipped>
guile: warning: failed to install locale
hint: Consider installing the `glibc-utf8-locales' or `glibc-locales' package and defining
`GUIX_LOCPATH', along these lines:

     guix package -i glibc-utf8-locales
     export GUIX_LOCPATH="$HOME/.guix-profile/lib/locale"

See the "Application Setup" section in the manual, for more info.

guix system: warning: cannot determine provenance for current system
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%


downloading from https://ci.guix.gnu.org/nar/lzip/0llx3y194278l5ksr4xh9kc64mh8nn8d-nss-certs-3.52.1 ...
 nss-certs-3.52.1  133KiB                                    186KiB/s 00:00 [########          ]  48.3%
           3 (apply-smob/1 #<catch-closure 7f10d4c80120>)
In ice-9/boot-9.scm:
    705:2  2 (call-with-prompt _ _ #<procedure default-prompt-handle?>)
In ice-9/eval.scm:
    619:8  1 (_ #(#(#<directory (guile-user) 7f10d490e140>)))
In guix/ui.scm:
  1936:12  0 (run-guix-command _ . _)

guix/ui.scm:1936:12: In procedure run-guix-command:
Throw to key `encoding-error' with args `("scm_to_stringn" "cannot convert wide string to output locale" 84 #f #f)'.
substitution of /gnu/store/0llx3y194278l5ksr4xh9kc64mh8nn8d-nss-certs-3.52.1 failed
killing process 5266
guix system: error: some substitutes for the outputs of derivation `/gnu/store/55mphxd7fz9km07s2zy1x26vcljh6yb5-nss-certs-3.52.1.drv' failed (usually happens due to networking issues); try `--fallback' to build derivation from source

The error is always when installing nss-certs, is entirely repeatable, and therefore not to do with a network connection.

I tried this about 4 months previous, and again today, and have been presented with exactly the same error.

The error always occurs at 48.3%.

A post on Reddit (https://www.reddit.com/r/GUIX/comments/hxrmzn/guix_system_error/) has the exact same error as this. The error even occurred at the same 48.3%!

I selected the Australian Locale (en_AU) during this installation. I am unsure why the locales error is present after installation. I ran the commands it suggested last time and the warning did not disappear, nor did the nss-certs error get resolved.

I can run --fallback, but to me this is ignoring an obvious issue with a vanilla system that should work out of the box.

Steps to reproduce:

* Create new VBox VM
  *   Install GuixSD Graphical
  *   Select Australia locale
  *   Select defaults
  *   boot into the system
  *  $ guix pull
  *  $ sudo guix system reconfigure /etc/config.scm

Original post

reply via email to

[Prev in Thread] Current Thread [Next in Thread]