[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#43035: gpg-agent can't find pinentry with linux-libre-5.8.3

From: Efraim Flashner
Subject: bug#43035: gpg-agent can't find pinentry with linux-libre-5.8.3
Date: Mon, 31 Aug 2020 22:20:36 +0300

On Tue, Aug 25, 2020 at 04:14:59PM -0400, Leo Famulari wrote:
> On Tue, Aug 25, 2020 at 12:45:45PM +0300, Efraim Flashner wrote:
> > This bug report sounds absurd to me but I don't see anything else
> > obvious that changed. I reconfigured with (kernel linux-libre) and the
> > gpg-agent couldn't find any pinentry. I even tried killing gpg-agent and
> > manually launching it and giving it the path to pinentry. I then changed
> > to (kernel linux-libre-5.7) and used the same commit to reconfigure and
> > gpg-agent started working as expected again.
> Weird! You should run gpg-agent with `strace -f` and see where it is
> looking.

I've attached the strace from gpg-agent when I tried to run 'gpg -s'
^C+d. I'm not really sure what it could be but it looks like I should
boot back into the 5.8.5 kernel generation and strace some more

Efraim Flashner   <efraim@flashner.co.il>   אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted

Attachment: gpg-agent.strace.gz
Description: application/gunzip

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]