[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#43420: icecat causes pulseaudio to crash

From: Nathan Dehnel
Subject: bug#43420: icecat causes pulseaudio to crash
Date: Thu, 17 Sep 2020 03:49:45 -0500

Actually, it crashes even if I unload module-jack-source and module-jack-sink.

Pulseaudio is set to autospawn by default, which is maybe why it seems like nothing is happening on your computer. Maybe try disabling autospawn and try running pulse in a shell.

On Wed, Sep 16, 2020 at 4:13 AM Mark H Weaver <mhw@netris.org> wrote:
Nathan Dehnel <ncdehnel@gmail.com> writes:

> So...playing a youtube video in icecat causes pulse to crash. You can
> play one video and it works, but it crashes if you open another tab or
> page with a video in it. Also skipping around the seekbar causes it to
> crash.
> bash-5.0$ pulseaudio
> W: [pulseaudio] pid.c: Stale PID file, overwriting.
> E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed:
> org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not
> provided by any .service files
> E: [pulseaudio] module-stream-restore.c: Assertion
> 'pa_hashmap_put(u->dbus_entries, de->entry_name, de) == 0' failed at
> modules/module-stream-restore.c:1406, function subscribe_callback().
> Aborting.

Unfortunately, I was unable to reproduce this on my x86_64 Guix system.

Starting with a fresh profile in icecat-68.12.0-guix0-preview1, I tried
watching 'https://www.youtube.com/watch?v=x6U2Un5kEdI', first using the
bundled 'ViewTube' extension (as happens with the default IceCat
configuration), and later with LibreJS and ViewTube disabled to test
Youtube's _javascript_ player.  I tried opening another video in another
tab while playing the first video, seeking around the file, etc, but
pulseaudio did not crash for me.

Is anyone else able to reproduce this?

Nathan: Would you like to try running "icecat -no-remote -p" and
creating a fresh new profile for testing purposes, and seeing if you can
reproduce the pulseaudio crash while using the new profile?  If not,
maybe try adding back your usual extensions to the test profile and
seeing if that makes a difference?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]