[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#48903: guix substitute: error: TLS error in procedure 'read_from_ses

From: Maxim Cournoyer
Subject: bug#48903: guix substitute: error: TLS error in procedure 'read_from_session_record_port': Error decoding the received TLS packet.
Date: Thu, 08 Jul 2021 09:59:22 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.2 (gnu/linux)


Ludovic Courtès <ludo@gnu.org> writes:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>> Ludovic Courtès <ludo@gnu.org> writes:
>>> Hi,
>>> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>>>> I've tried with the following modified version which runs multiple
>>>> threads in parallel (to mimic --max-jobs=4 on the daemon), and I've yet
>>>> to trigger it, although the hard drive is grinding heavily:
>>> Note that ‘--max-jobs=4’ leads guix-daemon to spawn 4 ‘guix substitute’
>>> processes, which is not what the script is doing here.
>> Oh!  I had overlooked that.  What the modified version did is create
>> threads rather than processes, right?
> Yes.
> So I’m not sure how to better test this.  Perhaps you could try
> introducing random delays in the loop (which could cause connections to
> go stale), using different substitute URLs, things like that.

I've tried some to reproduce the issue with the modified scripts below,
but in vain.  I'm not sure if my delay is inserted at the right place.
I also suspect that my attempt to shuffle the substitute-urls is not
really useful, as that's probably what would have happened anyway
(although I haven't followed in the code deeply enough to confirm).

Attachment: substitute-stress-launcher.sh
Description: Bourne shell script

Attachment: substitute-stress.scm
Description: Binary data



reply via email to

[Prev in Thread] Current Thread [Next in Thread]