[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#48335: Emacs is broken

From: zimoun
Subject: bug#48335: Emacs is broken
Date: Sun, 11 Jul 2021 20:47:32 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.1 (gnu/linux)


On Sun, 11 Jul 2021 at 11:33, Xinglu Chen <public@yoctocell.xyz> wrote:

>>>> Have you tried it in a container, like so:
>>>> $ guix time-machine --commit=652a03888e1609bd1a687326760436867fe2abb7 \
>>>>   -- environment -C --ad-hoc emacs -- emacs --version
>> It works for me.

Well, for me Emacs is not broken.  Your initial issue is about:

--8<---------------cut here---------------start------------->8---
libm17n-core.so.0: cannot open shared object file: No such file or directory
--8<---------------cut here---------------end--------------->8---

Now, is it solved for you?

Then this issue…

>>> Hmm, the commands fails with
>>> --8<---------------cut here---------------start------------->8---
>>> [...]
>>> building package cache...
>>> -builder for 
>>> `/gnu/store/k4ih7z9q04nghfvw4by007z8ijskghkn-guix-package-cache.drv' failed 
>>> to produce output path 
>>> `/gnu/store/n6qbwd1ahj3b4jzgp0np3fhvw9msgz06-guix-package-cache'
>>> build of /gnu/store/k4ih7z9q04nghfvw4by007z8ijskghkn-guix-package-cache.drv 
>>> failed
>>> View build log at 
>>> '/var/log/guix/drvs/k4/ih7z9q04nghfvw4by007z8ijskghkn-guix-package-cache.drv.bz2'.
>>> cannot build derivation 
>>> `/gnu/store/cfsrsvrz5c3mrxkm0ddlq9hy2bbvbl5c-profile.drv': 1 dependencies 
>>> couldn't be built
>>> guix time-machine: error: build of 
>>> `/gnu/store/cfsrsvrz5c3mrxkm0ddlq9hy2bbvbl5c-profile.drv' failed
>>> --8<---------------cut here---------------end--------------->8---

is another one.  And from my experience, it is about a conflict about
the channels.

>> Do you have a custom channel file?  Usually, this kind of error come
>> from a conflict between the packages from upstream (commit 652a03888)
>> and local packages.
> Yes, I do have a custom channel file

IMHO, the issue comes from this.  As Maxim suggested [1], you should

        Do you use channels?  If so, could you

        $ mv ~/.config/guix/channels.scm{,.bak}
        $ guix pull
        $ guix environment --ad-hoc emacs -- emacs --version

and it should fix the issue.  This…

> $ guix describe
> Generation 57 Jul 03 2021 11:44:49    (current)
>   flat 7b8353e
>     repository URL: https://github.com/flatwhatson/guix-channel
>     branch: master
>     commit: 7b8353ebbcf486e3344924d1cac0fa7ba47c371d
>   raingloom 7f5bf6d
>     repository URL: https://git.sr.ht/~raingloom/guix-packages
>     branch: master
>     commit: 7f5bf6d7783015c7899a6560f8bedc69b0d76393
>   guix-science 0bd456d
>     repository URL: https://github.com/guix-science/guix-science.git
>     branch: master
>     commit: 0bd456d2b0b25970e709ee408f1e1bc3f75b98ae
>   guix eef099a
>     repository URL: https://git.savannah.gnu.org/git/guix.git
>     branch: master
>     commit: eef099a2e1648032c571567c6da29ccd86e72058

…suggests you have a ~/.config/guix/channels.scm file and one of the
channel has a conflict with master.

1: <http://issues.guix.gnu.org/issue/48335#10>

All the best,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]