[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#49553: ARM installation

From: Zacchaeus Scheffer
Subject: bug#49553: ARM installation
Date: Tue, 13 Jul 2021 16:27:00 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Icedove/78.11.0

Hi bug-guix,

I tried running:

guix system image --system=armhf-linux -e '((@ (gnu system install) os-with-u-boot) (@ (gnu system install) installation-os) "aoeuthant")'

And got two unexpected behaviors.

First of all, I get the error:

|builder for `/gnu/store/05njkp7140yzkik9c3r3imfj0jdj68k1-dhcp-4.4.2-P1.tar.xz.drv' failed with exit code 1
build of /gnu/store/05njkp7140yzkik9c3r3imfj0jdj68k1-dhcp-4.4.2-P1.tar.xz.drv failed
View build log at '/var/log/guix/drvs/05/njkp7140yzkik9c3r3imfj0jdj68k1-dhcp-4.4.2-P1.tar.xz.drv.bz2'.
cannot build derivation `/gnu/store/4nswzq8wdnj77z16v3gmjb2b31pphh7f-isc-dhcp-4.4.2-P1.drv': 1 dependencies couldn't be built
guix system: error: build of `/gnu/store/4nswzq8wdnj77z16v3gmjb2b31pphh7f-isc-dhcp-4.4.2-P1.drv' failed

(log attached here)

According to https://guix.gnu.org/manual/en/html_node/Building-the-Installation-Image.html, specifying an invalid board (notice "aoeuthant" at the end of the command I tried) should print a list of possible boards.  A list of possible boards was NOT printed, though it is possible this was caused by the first error, though I would expect a list of boards before it tries to make the image.


Attachment: njkp7140yzkik9c3r3imfj0jdj68k1-dhcp-4.4.2-P1.tar.xz.drv.bz2
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]