[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#49753: MuseScore's default SoundFont is broken (Was: Re: musescore d

From: Giovanni Biscuolo
Subject: bug#49753: MuseScore's default SoundFont is broken (Was: Re: musescore does not play sounds (Not a valid SNDFILE* pointer))
Date: Wed, 28 Jul 2021 18:33:57 +0200

Hello Leo,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

> Don't forget to keep the ML in the address line.

Sorry I forgot it.


>> So it seems that also fluidsynth is not able to load that SoundFont
>> [1]

> Ah, yes, I recall not being able to load that font with FluidSynth as
> well.  Back then I thought it was an error in FluidSynth, but it does
> appear to be an issue with the SoundFont then if not even MuseScore
> loads it.

Please are you reproducing the same error?

I tried installing musescore3 (v. 3.2.3) from Debian stable and AFAIU
that SoundFont is loaded (with a lot of warnings):

--8<---------------cut here---------------start------------->8---

Loading soundfont: /usr/share/mscore3-3.2/sound/sf3/MuseScore_General.sf3
Loading soundfont: /home/giovanni/MuseScore3/SoundFonts/GeneralUser GS 
SoundFont(/home/giovanni/MuseScore3/SoundFonts/GeneralUser GS v1.471.sf2) 
Sample(Grand Piano-D1) start(0) startloop(35640) endloop(70786) end(70787) 
smaller than SoundFont 2.04 spec chapter 7.10 recommendation
Loading soundfont: /usr/share/mscore3-3.2/sound/sf3/MuseScore_General.sf3
SoundFont(/usr/share/mscore3-3.2/sound/sf3/MuseScore_General.sf3) Sample(Flute 
F#5) start(0) startloop(19435) endloop(29952) end(29955) smaller than SoundFont 
2.04 spec chapter 7.10 recommendation

--8<---------------cut here---------------end--------------->8---

musescore installed from Debian plays sounds using MuseScore_General.sf3


>> Could it be a bug in some library?

> If so, then it's two different libraries,

AFAIU the error

--8<---------------cut here---------------start------------->8---

Sample::decompressOggVorbis: open failed: Not a valid SNDFILE* pointer.

--8<---------------cut here---------------end--------------->8---

/seems/ to come from libsndfile [1], an input for both fluidsynth and

> as MuseScore doesn't use FluidSynth for MIDI synthesis – it's more
> likely that the font is simply broken.

AFAIU this is not the case

> It would be nice to investigate when that font first broke or if it
> ever worked.

I'll try to do it in the coming days


Happy hacking! Gio'

[1] https://github.com/michaelwu/libsndfile/blob/master/src/sndfile.c

Giovanni Biscuolo

Xelera IT Infrastructures

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]