[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lockup in clean build from cvs in exec

From: David Walter
Subject: lockup in clean build from cvs in exec
Date: Wed, 26 Jun 2002 00:08:09 -0400
User-agent: Gnus/5.090007 (Oort Gnus v0.07) XEmacs/21.4 (Common Lisp, i386-debian-linux)

I am at a loss as to how to build the current cvs version of the Hurd.

At first I  thought I was  having incompatibilities with my home built

I tried gradually eliminating different parts of the build, and now am
down to the following with the same results as mentioned below.

0. mke2fs -o hurd /dev/hd0s2

1. unpacked gnu-20020523.tar.gz into the root directory using
   tar --same-owner -xzvpf gnu-20020523.tar.gz

2. ./native-install (twice) as per installation doc.

3.  apt-get the tool chain for  native build (gcc, cpp, make, texinfo,
autoconf, mig...) (some  configuration  -- settrans  /servers/socket/2
pfinet --address ....)

4. cd /opt; rm -rf hurd;
cvs -d :pserver:anoncvs@subversions.gnu.org:/cvsroot/hurd login

5. cvs -d :pserver:anoncvs@subversions.gnu.org:/cvsroot/hurd co hurd

6. cd hurd; mkdir build; autoconf; cd  build; ../configure; make; make

7. reboot.

8. freeze with

   start /hurd/ext2fs.static: Hurd server bootstrap: 
ext2fs.static[device:hd0s2] exec


The grub kernel/modules commands  worked with the existing version  of
gnumach and hurd from the tarball.

I have tried with both versions of the kernel(gnumach 1.2/1.3).

The only reason  that I was doing  this was to  build a debug  version
whose symbols I was sure of to try to pick up on debugging the problem
I am having with a lock up during file system access.

But now it appears that I am having a different problem.

I had a working build of libc/gnumach/the Hurd previously. 

I don't know if this is somehow to do with the current version of gcc? 
libc?  Brain fart on my part :-/

I  have tried  building all of  these  and this latest  attempt was to
start from what I understand the current build environment should be.

Is it  possible to attach  to the process at this  time using a serial
cable?  If so, and if necessary  if someone can point  me to the steps
for this,  I  will  take a look    at  poking around to   provide  the
information  necessary by remote debugging   of this, using a separate


Hope springs eternal!

/ \

reply via email to

[Prev in Thread] Current Thread [Next in Thread]