[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Weird GNUMach crash

From: James Morrison
Subject: Re: Weird GNUMach crash
Date: 07 Feb 2004 13:54:24 -0500
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

Marco Gerards <metgerards@student.han.nl> writes:

> Hi,
> While I tried to generate a segfault it crashed GNUMach (1.x, I have
> tested both CVS and 1.2)  with this error:
> panic: zalloc: zone kalloc.8192 exhausted
> (There is a small pause here and a bit of disk activity/ flashing IDE LEDs)
> hd1: irq timeout: status=0x58 { DriveReady SeekComplete DataRequest }
> hd0: disabled DMA
> hd1: disabled DMA
> ide0: reset: success
> (And here my box reboots after some seconds)
> Here is how I produced this result (and I can generate this problem
> anytime, so it is possible to debug this).  The weird thing about this
> problem is that it only happens when I run the test program from my
> /home partition (which lives on hd0s1).
> Here is what I did before GNUMach crashed:
> marco@c366:~$ cd src/tests
> marco@c366:~/src/tests$ cat crash.c
> int
> main (int argc, char *argv[])
> {
>   int *p = 0;
>   *p = 213;
>   return 0;
> }
> marco@c366:~/src/tests$ gcc crash.c -o crash
> marco@c366:~/src/tests$ ./crash
> Segmentation fault
> marco@c366:~/src/tests$ ./crash
> Does someone have any idea what the problem might be and how I can
> debug this?  I am willing to do so but I am afraid that it can be
> quite hard (and that I do not have the experience and perhaps not
> enough knowledge) so I would appreciate some help (a pointer in the
> right direction).
> Are other people able to reproduce the same?  Please notice that you
> will need to test this using a second partition.
> Thanks,
> Marco

 What is your crash server setup to do?  Have you tried attached gdb to
the crash server?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]