[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

The bug of rpctrace? when tracing the translator

From: Da Zheng
Subject: The bug of rpctrace? when tracing the translator
Date: Mon, 18 May 2009 23:38:04 +0100
User-agent: Thunderbird (Macintosh/20090302)


I see the bug reported by youpi at http://www.gnu.org/software/hurd/hurd/debugging/rpctrace.html:
rpctrace hangs when it traces the translator.

I tried several translators: hello, ext2fs, pfinet.
I didn't see any problems when I trace hello.
When ext2fs is traced by rpctrace, it can run but I cannot close it with "settrans -g node". I cannot trace pfinet. When I run "settrans -ac 2 hurd/utils/rpctrace /hurd/pfinet -i eth0 -a -g -m", pfinet dies.

I also tried to kill rpctrace or the translator. I didn't see the Mach panic, either.

So my questions are:
Is this bug reproducible every time?
or has the bug been fixed? if it has, which patch was used?
or does the bug only appear when it traces some specific translators?

This bug is very similar to the one I have when I develop boot.
I hope I can fix the bug in boot by understanding this bug in rpctrace.

Thank you,
Zheng Da

reply via email to

[Prev in Thread] Current Thread [Next in Thread]