[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU Hurd Installation

From: Jakub Daniel
Subject: Re: GNU Hurd Installation
Date: Tue, 3 Nov 2009 12:42:48 +0100

Thank You very much, more memory solved the freezing.
But now I am facing another problem with grub2. I am not
sure whether this question belongs here but after flawless
native-install i try to run update-grub and i get only

grub-probe: error: cannot find a device for /.

# /boot/grub/device.map
(hd0)    /dev/hd0

But I tried adding various things here none of them worked.

Actually even when I try to boot hurd like:

qemu -hda hd0.img -m 768 # Where hd0 is my hurd disk image

without grub floppy or whatever, qemu dies and prints out
the content of all registers saying that i probably accessed memory
out of range. I guess this means grub isn't installed to be loaded
when necessary.

I tried grub-install. But I got only another error telling me that
it doesn't know what device the /boot/grub directory should be at.
Or at least this is how I interpreted it to myself.

Tried running it like:

grub-install hd0
grub-install --root-directory=/ hd0

grub-install hd0s1
grub-install --root-directory=/ hd0s1

Obviously didn't help. Most probably I am missing something or I
missinterpreted something but maybe it can be that some config
file was not set by native-install and needs to be set manually.

I appologize if this is not supposed to be asked here.

Best wishes
Jakub Daniel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]