[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: uid_t vs. gid_t (was: The Hurdish Package Manager)

From: Patrik Olsson
Subject: Re: uid_t vs. gid_t (was: The Hurdish Package Manager)
Date: Mon, 12 Apr 2010 21:11:52 +0200

On Sat, 2010-04-10 at 12:09 +0200, olafBuddenhagen@gmx.net wrote:
> Hi,
> On Fri, Apr 09, 2010 at 11:42:25AM +0200, Patrik Olsson wrote:
> > I have found one thing that seems incorrect in
> > hurd.git/hurd/password.defs. See the parameter/field "group" in
> > "password_check_group"? Shouldn't it be of type gid_t and not uid_t?
> Yeah, gid_t would definitely be clearer -- though technically they are
> the same...
> Note that in many places, an idarray_t is used instead of a single uid_t
> or gid_t; which is *always* defined to uid_t.
> gid_t in fact is used only in a single place so far...
> Still, this probably should be fixed. How about a patch? :-)

Well, if it ain't broken, then why fix it? :-)

I think that going through all those folders to change the type will
take a whole day. It's not really easy to make a script for it either
since not all uid_t should be changed, only some. Besides, I cannot
check if the software will still build after the changes (or if it will
break other packages that assume the old type).


Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]