[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tmpfs for Maksym Planeta

From: Maksym Planeta
Subject: Re: tmpfs for Maksym Planeta
Date: Mon, 17 Oct 2011 00:13:29 +0300

On Thu, 13/10/2011 at 14:40 +0200, Thomas Schwinge wrote:

>   * Get the ``File System Exerciser'' running on GNU/Hurd (no idea if
>     there's any porting required).  The one I linked from
> <http://www.bddebian.com:8888/~hurd-web/open_issues/file_system_exerciser/>
>     appears to be the ``definitive version''.

I've tried two edition of fsx and both of them work with trivial
workaround for msync:
$ diff fsx-linux.c fsx-linux.c.old
> #define msync(...) 0

fsx-linux.c should be compiled with -Dlinux flag.

>   * Run it on a tmpfs file system and see what happens.

The behavior of fsx depends on platform I run Hurd on. For qemu fsx
hangs at once. On real PC I get following:
$ settrans -c foo /hurd/tmpfs 1M
$ touch foo/bar
$ ./fsx foo/bar
truncating to largest ever: 0x13e76
Resource lost

I think that this behavior caused by bug

>   * For comparison, also run it on an ext2fs file system.  This is for
>     comparison, which errors are due to the tmpfs/ext2fs difference, and
>     which are due to libdiskfs (used both by tmpfs and ext2fs), etc.  If
>     you happen to have a NFS setup at home (only client on GNU Hurd), you
>     can also run it on a file system backed by the nfs translator.  If
>     you haven't, I (as well as Olaf?) can help with the latter testing.

I've tested fsx on ext2fs and it worked without any error. Than I tested
it on ext2fs, mounted on ramdisk. Everything worked too. NFS I do later,
but as can be seen fsx works.

Maksym Planeta <mcsim.planeta@gmail.com>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]