[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug#802593: gcl: FTBFS on hurd-i386

From: Camm Maguire
Subject: Re: Bug#802593: gcl: FTBFS on hurd-i386
Date: Thu, 22 Oct 2015 10:59:23 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.4 (gnu/linux)

Greetings, and thanks again for your work on this!

Svante Signell <svante.signell@gmail.com> writes:

> On Thu, 2015-10-22 at 11:30 +0200, Svante Signell wrote:
>> Hi,
>> Cc: bug-hurd
>>  Running your test program at
>> https://lists.debian.org/debian-hurd/2013/07/msg00038.html
>> on a recent kernel gives an even lower limit for memory fragmentation.
>> 0x70000000 fails now, and I used 0x6b000000 in the latest build. The
>> acl2 assertion still happens. Builds of maxima, hol88 will be tried
>> next.
> Update:
> hol88 builds with one manual interrupt:
> Fast links are on: do (si::use-fast-links nil) for debugging
> Signalled by %AP.
> Broken at %AP.  Type :H for Help.
>     1  Return to top level. 
> Fast links are on: do (si::use-fast-links nil) for debugging
> Signalled by %AP.

I think you might be using an older gcl, as the symbols have recently
moved among different packages.  If you try the latest versions in
debian sid with your sysconf patch for gcl, that should work.
Otherwise, pleast let me know.

> Broken at %AP.
>     1 (abort) Return to debug level 1. 
>     2  Return to top level. 
>>>> <entered ^D here>
> Makefile:36: recipe for target 'latex_type_pp.ml' failed
> make[4]: *** [latex_type_pp.ml] Error 255
> make[4]: Leaving directory
> '/home/srs/DEBs/hol88/hol88-2.02.19940316/Library/latex-hol'
> maxima still FTBFS at the same place.
> Seems like there are errors when running gcl for both packages:
> task(9610) decreasing a bogus port 1701869637 by 1, most probably a bug.

Interesting.  My general experience has been lockups almost impossible
to debug and do anything but a kill -9.

> For maxima:
> /bin/bash -c gcl -batch -eval '(progn (load
> "../lisp-utils/defsystem.lisp") (funcall (intern
> (symbol-name :operate-on-system) :mk) "maxima" :load :verbose t) (when
> (fboundp (quote si::sgc-on))(si::sgc-on t)) (si:save-system
> "binary-gcl/maxima"))'
> I tried to issue that command manually but it fails. How to run gcl from
> the commandline?

>From the maxima source tree you can do
cd src
GCL_ANSI=t gcl
>(progn (load "../lisp-utils/defsystem.lisp") (funcall (intern (symbol-name 
>:operate-on-system) :mk) "maxima" :load :verbose t) (when (fboundp (quote 
>si::sgc-on))(si::sgc-on t)) (si:save-system "binary-gcl/maxima"))

You can also precede with (si::use-fast-links nil) if you want lisp

Take care,
Camm Maguire                                        camm@maguirefamily.org
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]